Error while publishing an app

Which tool versions are you using?

SDK: v14.2.1
Platform: v23.06.5
Python: v3.9.13
Isolation mode: venv

Current Behavior

Apps works fine in Workspace but fails to publish.

Expected Behavior

App should publish

Context (optional, but preferred)

I am trying to integrate my Rhino-Grasshopper file with VIKTOR by following the VIKTOR tutorial. I have succeeded to incorporate my grasshopper file, which works fine in Development Workspace

when tried to publish the same app it is giving an error, basically it is searching for the old file “sample_app.3dm” instead of my replaced file “Viktor_Project.3dm”. I have replaced my custom file in place of file given by VIKTOR.

Please guide me on this.
Thank you


When you are working inside a git repository the CLI will automatically use git to gather all the files that your are tracking using git. From your comment I deduce that you changed the file. Did you also add and commit the file properly to your current branch?

An alternative would be to use the --use-filesystem flag while publishing to have the CLI gather the files by walking over the file tree of your app folder.

1 Like

It worked. Thank you for your clarification.