Manifest misses entity type ModelController, which is present in database

Which tool versions are you using?

SDK: v14.2.1
Platform: v23.06.5
Python: v3.9.13
Isolation mode: venv

Current Behavior

Not able to publish an app.

Expected Behavior

The script is working is development workspace and should publish.

Context (optional, but preferred)

I am trying to integrate Rhino-Grasshopper file with VIKTOR. Previously I had an issue which was solved but again I am getting a Manifest error. I have tried viktor-cli clear but still it is not working for me.

Thank you.


Hi Darshan,

Within the same app the name of an entity type cannot be changed between versions. The name of the entity type is defined by the name you give to your controller class (the class that inherits from ViktorController). Did you perhaps change that since your last app publish?

For more information on publishing and the limitations: Publishing an app | VIKTOR Documentation.



I created a new file and restarted the whole process. I was able to publish my app.
Thank you for all your suggestions and effort.

However, I still have some doubts which I have posed in the community. I request you to please have a look.

Thank you.