ModuleNotFoundError: No module named 'connector'


I have the exact same error as someone a year ago, but restarting the Docker Desktop does not work.


./viktor-cli start --app-dir app-name


Traceback (most recent call last):
  File "<string>", line 1, in <module>
ModuleNotFoundError: No module named 'connector'

Do you have another way to fix this problem?

Kind regards,

Colin Groen

Reinstalling the app does not work either.


viktor-cli install --app-dir app-name


The application has successfully been installed. Use the commmand 'viktor-cli start' to start your app.

When starting the app I get the ModuleNotFoundError. Furthermore, when I go to my development workspace, I cannot see the entities on the left side (which is weird, because I always saw that, even if the app wasn’t started yet):

Reloading doesn’t work either.

Hope someone can help me.

Hi Colin,

Could you, similar to the other issue earlier this year you are referring to, check whether you have a valid requirements.txt file (while you are there, could you also tell me the sdk version you’re using?) and check whether there is a connector file in the pip-cache folder?

Issue was resolved after switching to venv as the isolation method on windows.

Hi Maarten,
I’m having the same error as Colin now. Can you explain how to ‘switch to venv as the isolation method on windows’? I don’t know how to do that. Unfortunately Colin is not available today.

You can run viktor-cli configure to change isolation mode.

Hi! Should I also move my repository outside the \\wsl$\ubuntu path? And what do I have to choose here? None of the three options seem to work…

Marlies and I had a call to resolve the issue.

Moving to venv as isolation mode fixed the problem.

WSL2 / Ubuntu both /usr/bin and /bin hold a Python installation, so either option can be selected.

@rdejonge @mweehuizen My company gave me a new laptop. On this laptop, I have the same issue when starting the app: ModuleNotFoundError: No module named 'connector'

Do you know if there is any other solution for this problem, other then switching to the venv modus? My whole team is working with docker, I dont want to be the only one who doesn’t…