No module named 'connector'

Hi. Wednesday my app was working fine, and then since yesterday i get the following message when trying to start

C:\Users\nbouwman\viktor-apps>viktor-cli.exe start --app-dir bovenleiding
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ModuleNotFoundError: No module named 'connector'

have tried reinstalling and then i get the following error:

C:\Users\nbouwman\viktor-apps>viktor-cli.exe install --app-dir bovenleiding
SDK version: 12.7.0 Connector version: 5.9.2
Creating app specific install dir viktor-docs
Creating app specific install dir viktor-stubs
Creating app specific install dir pip-cache
Creating app specific install dir signals
ERROR: Could not open requirements file: [Errno 21] Is a directory: '/usr/src/app/requirements.txt'

i havent changed really anything in the app.
Any suggestions?

Hi Natalie,

Could you confirm that the requirements.txt is indeed a file as it should be, located directly in the “bovenleiding” directory?

Also did you try to start a different app? Please do not reinstall if it doesn’t, to allow us to inspect the viktor-installs.

Hi Kevin,
the requirements.txt is definitely a txt file in the app folder

other apps give the same message. i tried 2 apps. one was still in the “old” folder system so it automatically moved/updated it (i.e. old cli method) but still gave the same message

Alright, could you navigate to the pip-cache folder and confirm that a file called connector.... exists? You should find it in:



This looks as it should, so it feels like a docker issue. Can you try to restart your Docker Desktop?

That seems to have worked.
I restarted, had to put in a password for sharing files. but strange that just starting up in the morning didnt have the same effect.
I will be very pleased when you move away from Docker!

Good to hear!

I will be very pleased when you move away from Docker!

Stay tuned! :wink: