Warning message starting viktor

When I am trying to build my-first-app, according to the tuturial create first app. I get a warning message in my CMD after I start the app with"viktor-cli". The warning message is:

C:\Users\bolu\AppData\Local\Programs\Python\Python310\lib\multiprocessing\process.py:315: UserWarning: app.Controller: A ‘parametrization’ is defined without any fields. This will be treated as if there is no parametrization at all (i.e. a views-only editor).

Because of this I can nog edit my parametrization.

Hi Luuk, welcome to the community!

I’ve flagged this post as a support question.
Can you clarify a bit more what your situation is:

  • Can you successfully open the app in your browser despite this warning?
  • What do you mean that you can not edit your parametrization? You keep getting the same warning, even if you add for example a numberfield?

I can successfully open the browser app, I can edit both the parametrization class and the controller class. If I follow the tuturial I can visualisize the beam and I can also edit the properties of the beam(inside the controller clase), but when I add a numberfield it does not show in the browser(there is no input field inside the browser). I get no warning messages after I started the app.

I also tried to download python and viktor again, but it does not work

Hi Luuk, did you refresh your browser when you added a field in the parametrization?

Yes I did, because when I refresh i does update the properties of the beam(when i change them)

I also tried to download it on another computer, but it I still get the same warning message

Can you copy the code snippet of your parametrization (including the NumberField) that is causing the UserWarning?

I forgot to put the parametrization=Parametrization inside the controller class that was the reason, now it works. Not so smart :sweat_smile: Thank you for your help!

1 Like