Viktor-cli install gives Error: The file or directory is not a reparse point

Hi All,

I get this error: “The file or directory is not a reparse point” when I use the viktor-cli install command. Any idea on how to resolve this error?

I’m running viktor version 0.32.0 and Python 3.11.7

Thank you.

Hi there,

Welcome to the forum, thanks for posting!

Could you give a little more context? For instance, have you installed this specific application before successfully? If so, what changed between then and this issue?
For that matter, have you ever successfully installed any application or is this the first?

If I’d have to wager a wild guess I’m thinking you are using some outside data sources in your app (e.g. an excel sheet or json file of sorts)? If those are not stored directly in the app files or imported through an appropriate API service, this could cause the types of errors you are facing.

Looking forward to some more context, hopefully that can shed some more light on the situation.

Hi Daniel,

I got the same error when I was installing Viktor at the point when the setup tried to install the demo app was being installed. I’m still getting the same error when I created an empty app and issued the install command in terminal.

I’m not using any data sources. This is an empty app I created following the introductory viktor tutorial.


We solved it in a private conversation but the issue turned out to be a Python installation from the windows app store which didn’t work.

Re-installing Python from the official installer resolved the problems.