Viktor-cli install error

When running a viktor-cli install I get the following error:

$ viktor-cli install
Creating app specific install dir signals
Creating virtual environment
Requirement already satisfied: pip in c:\users<user_provide><project>\venv\lib\site-packages (23.0.1)
ERROR: To use the truststore feature, ‘truststore’ must be installed into pip’s current environment.

Exiting because of an error: installation of the app failed

How could I resolve this?

I’m running Version: v0.31.1

Hi Thomas,

I suspect that this is due to the viktor-cli that was upgraded, but will have to check to make sure. I will keep you posted the moment I have more information.

Hi Marcel,

I can confirmed, I rolled back to v0.30.3 and don’t get this error.

Hi Thomas,

Thanks for the bug report.

Can you share which Python version is installed on your machine? Are you on Windows or Linux? And are you using venv or docker as isolation mode?

Edit: from the log you shared I see that you are using venv



HI @rdejonge ,

Running on Windows, in venv isolation mode.
Python version used in 3.10.
Note that the python installation path used in viktor-cli configure point to a anaconda environment path.

Is there is a way to display more info from the command? I don’t see a verbose option on the install command

Ok thanks, for the additional information.

The CLI tries to upgrade pip to be able use the truststore feature. This is supported for python versions 3.10+, which is what we check beforehand. After that we run a pip upgrade command to get the latest version. From your logs it appears that no new version can be found. However, it should be available as can be seen from pip · PyPI.

Is the version of pip pinned to a specific version in your anaconda environment by any chance? Or is updating or installing Python packages in someway limited on your machine?



I guess that what could cause and issue. In our environment, pypi is actually block on the network. This is a limitation @mslootweg is familiar with.

Would you know which pip version is expected?

Currently, the conda environment include 23.3.1 which is the latest version available on conda-forge.

That is indeed the version that is required. So I think something else is going on. Do you have time for a short call tomorrow afternoon?

I have just created a version of the CLI that also allows you to install without the truststore feature flag.

You can get the latest CLI with viktor-cli upgrade, subsequently you can install with viktor-cli install --use-truststore=false

1 Like

Hi @rdejonge,

I upgraded to the new version (v0.31.2) and this is now working with the --use-truststore=false flag.

> viktor-cli install --use-truststore=false
Creating app specific install dir signals
Creating virtual environment
Looking in indexes:
Collecting viktor-connector==5.21.0
Downloading (580 kB)
-------------------------------------- 580.2/580.2 kB 6.1 MB/s eta 0:00:00
Installing collected packages: viktor-connector
Successfully installed viktor-connector-5.21.0
The application has successfully been installed. Use the commmand ‘viktor-cli start’ to start your app.

I’m off for the rest of the week, but I have a call with @mslootweg on Monday. Maybe you can join us then. I’ll send you the invite.

Thank you.

Good to hear!

Thanks for the invite, I will join!