Timeout with grasshopper rhino.compute

I am running a grasshopper script from Viktor.
I am now getting a timeout error on my rhino.compute console.
I have amended the timeout in the grasshopper solver settings but the original timeout still shows in the compute console.
Is there something else that I should be doing?

[11:50:27 ERR] Connection id "0HN39OE03KEM8", Request id "0HN39OE03KEM8:00000002": An unhandled exception was thrown by the application.
System.Threading.Tasks.TaskCanceledException: The request was canceled due to the configured HttpClient.Timeout of 100 seconds elapsing.
 ---> System.TimeoutException: The operation was canceled.

Hi Natalie,

Just did some testing with the solution in this thread.

I added RHINO_COMPUTE_TIMEOUT to my env variables with 5 seconds and tried a time.sleep in Grasshopper. This errors after 5 seconds.

It seems to work, although it will return a json encoding error (as the result of your compute call is immediately tried to be cast to json).

Where do you do this?
I tried just in the terminal for my development environment but didnt seem to change anything.

ive printed out the os.getenv(“RHINO_COMPUTE_TIMEOUT”)
that gives the new value, but my rhino.compute still times out at the original value

Okay thanks for including that print. Did you restart your server?

Its running locally on my computer.
I’ve restarted rhino, and the worker, but not my whole laptop.

added: laptop also restarted to no effect

Are you running this as a server or through Hops? In the latter, could you try also setting your Hops timeout setting?

In Grasshopper → File → Preferences → Timeout

I have the Hops already as a higher timeout.