Table Header to small for header text

Hi,

I’m trying to change the width of the header of a column of an input table. This is because you couldn’t read what the headers are, see the screenshot below.

I tried to change the flex of each Header, but the table uses the whole screen this is not possible. Does someone know how to fix this or how to get a slider in an input table.

Regards,
Jip

Hi Jip,

It looks like a very big table (as in, a lot of columns) you are trying to use! I’m not sure setting the flex of every column would be the best way to go (even if you could), because it would probably lead to a horizontal scrollbar, also not the nicest user experience. Some quick thoughts about things you could try:

  • Is it absolutely necessary to have all these columns in 1 table? If you could split them up over multiple tables, or add a table per Q (whatever your Q1, Q2 etc is) that might be a lot clearer and cleaner
  • Did you know the user can expand the input side of the an editor by clicking this button on the border between the input and output side?
    image
  • Perhaps you could try to use an input-only editor, or use pages or steps to break up large tables into multiple blocks, or give the user an input-only page before moving to a page that includes a visualisation
  • Or maybe you could use the specific setting of the parametrization width to create more space for your table

Hopefully there are some usefull ideas in there for you!

Hi,

I would like to have a horizontal scrollbar, but if I set the flex of every column it would not give me a scrollbar. I have tried all the other things but it still does not make a difference. Besides that I could not split the table.

Kind regards,
Jip

Hi Jip,

The horizontal scrollbar should definitely appear if the table doesn’t fit! It appears if you hover underneath the table with your mouse:

Does it not show up for you?
You can also drag columns wider with your mouse:

And finally, did you manage to try the button I suggested? It pops out the parametrization to be screenwide:
example_big_table

Hi @jip.ridderbos,

In the meantime I have also asked some of my colleagues about this, and currently the width of columns can not be controlled by you as a developer. The flex keyword is not used, and the table is always drawn to fill the width of the parametrization. I have added your request to be able to control column width to an internal issue on our board.

Hi @rweigand

Thank you!