Step 3 of migration developers environment does not work

I followed the first and the second step of the migration (viktor-cli upgrade and viktor-cli configure). However when running the third step (viktor-cli start), it says that there is no app installation found. App installation was not found. The app should be installed with 'viktor-cli install' before starting the app. No old app installation directory found. Exiting because of an error: app is not (properly) installed. However running viktor-cli install doesn’t work either. How can I fix this?

Hi Marlies,

Are you running this command inside your specific app folder?

otherwise navigate to the folder and try to start the app again:

cd <app_folder>
viktor-cli start

When you ran viktor-cli install what was the resulting message?

Hi @marliesbuijs,

Did you by any chance select a different isolation mode while running configure? This might be the reason for the CLI to not find the previous app installation.

Regards,

Raoul

Hi! This happens when running viktor-cli install
`root@DESKTOP-3N0LET7:~/potentiescan# viktor-cli install

SDK version: 13.0.0 Connector version: 5.13.1
Creating app specific install dir pip-cache
Creating app specific install dir signals
Exiting because of an error: exec: “docker”: executable file not found in $PATH`

I believe I only hit enter. This is what it looks like:

This looks like it is unrelated to the development environment migration. But, somehow ‘docker’ isn’t recognized anymore. Are you using the viktor-cli on WSL 2? Is Docker Desktop running on Windows? Also check that in the settings you have selected 'Use the WSL 2 based engine.

A similar problem seems to be described here: docker command not working in WSL2 · Issue #7535 · docker/for-win · GitHub