Problems viktor-cli installing venv - acces to requirement viktor==12.10.0 (from versions: none)

As I changed repo, I thought of installing the application using the “new” venv option without docker/WSL etc. check-system works fine, however I can’t install the application as it can’t install the viktor package.
See error below.

Any idea what could go wrong?


Hi Johan,

The virtual environment uses your system Python installation to create the virtual environment. This means that the Python version used in the virtual environment corresponds to the version of Python you have installed on your system. We currently support versions 3.7-3.10. What is the output of python --version in your cmd prompt? I think you receive the error message from pip because you are trying to install the SDK for a version of Python that is not supported.



Current version 3.8.5

It seems setting docker instead of venv doesn’t give any problems.
Currently using following env vars:


I don’t think these conflict, but thought about sharing just in case.

From the name of the Python directories it seems that you have installed a 32-bit version of Python. We currently only support 64-bit Python.

Thanks for the help. I believe this could be the problem as it also differs from my collegue which uses 64-bit. I will try it tomorrow afternoon