Yesterday my code was working completely normally but I come back today and start it and get the error “ImportError: cannot open shared object file: No such file or directory”. I was wondering if this was something you all had run into before? I am running the code through a GitHub Codespace in a virtual environment. Any information would be incredible.

Hi @abevington ,

I’m looking at other reports of the error that you are reporting. Did you look into this thread yet?

yes I have tried that and it is not working. I included my viktor.config.toml file below to make sure I don’t have dumb mistakes but I changed it and ran viktor-cli clean-start and also tried viktor-cli install and all the other options I could find but they always gave me the same error when I was trying to start the app. I am running on python 3.10 in a codespace

app_type = 'editor'
# assets_path = 'assets'
packages = ["libgl1"]
python_version = '3.10'  # '3.9' | '3.10' | '3.11' | '3.12'
# welcome_text = ''
# registered_name = 'app-name'

I am wondering whether this error will persist if you would develop locally. Is there a reason why you are using CodeSpaces rather than local development?

I am using codespaces because the company laptop has an insane amount of firewalls so using pip is a nightmare so I try and avoid using it outside of codespaces where the firewall doesn’t apply as best I can. I will try and run it locally though and see how this works

Let’s try to resolve this step by step. Do you recall at what part of your development it still worked? Was a new dependency introduced?

It was working until I tried to use the library LandingAI. After this it started to give me the error. It does not happen if I create an application without using that library so I have found the cause but I am not sure why that library specifically is triggering the error

Just got informed by @khameeteman that viktor-cli install does not install the system packages. Therefore, check that these are installed on CodeSpaces with the following:

  • sudo apt-get update
  • sudo apt-get install libgl1
1 Like