IDEA worker exit status 3221225477

When using IDEA I get the following error.

image

However if I open the corresponding input.xml with the IDEA Rcs controller test application i get:

image"

Is there any information available regarding this error?
It used to work before as far as I know. But I can’t really find out where the bug is comming from.

Thanks in advance!

Hi Johan,

What version of the worker are you using? And what version of IDEA?

Idea version 21.0.4.859.
Worker version: v4.10.1

@rdejonge could it be that it depends on the size?
I have tried to build the model bit by bit and at some point (adding multiple check_sections) it sometimes works and sometimes returns the model cannot be generated)

The only thing I changed was My=200500 to My=203500 and it works…

That is peculiar. I am not entirely sure, but in that case it is something that is happening in the IOM code.

So to be clear if you use the original model and change the value of My you do not get an error anymore?

I can imagine that there might be some limits regarding the amount of extremes that are added to the model. Was the model you are trying to evaluate very large?

it is a little bit large, however it used to work perfectely before:

                # for sls, uls, fat in itertools.zip_longest(sls_loads, uls_loads, fat_loads, fillvalue={"N": 0, "My": 0, "Vy": 0}):
                for i in range(2):
                    freq = LoadingSLS(ResultOfInternalForces(N=-100000, My=21002))
                    fund = LoadingULS(ResultOfInternalForces(N=-88888, My=203600))
                    check_section.create_extreme(frequent=freq, fundamental=fund)

If i use the bottom loop i in range 2, it works fine. If i do the same for a larger loop (commented line) it crashes.

That is interesting. Do you know if anything changed? SDK version, worker version, IDEA version? That might help in narrowing down where the problem might be

We changed to a previous version. It works now. So most likely (as always) it lies somewhere in the code. It was kinda strange though that by changing the value of the forces it resulted in an error before.
Nevertheless this topic may be closed/removed