Excel worker error

SDK: v12.5.0
Platform: v5.1.12

I am working on an app which uses the Excel worker, the excel I am using it’s quite big, but normally the app works, even if it’s slow. However, even if I was testing with similar input today, I got this error:

The macros from excel generate graphs as svgs, which are then retrieved by the generic worker, but, for some reason the excel worker gets sometimes stuck there as well. So I can see in the excel worker promt that it’s sending results to the generic worker, but then it just times out. I tried to increase the timeout time, but with no succes.

Ideally, I would like to know what causes these errors, so that I can at least print a message to the user to notify them what should be changed in the input, for example.


Hi Monica,

The message The remote procedure call failed indicates that the COM server (which is used by the worker to communicate with Excel) was not able to execute the command or crashed. It is not super straight forward to debug an error like this as it happens somewhere in Windows and not in the worker. I also see from the logs that the worker received a command to stop job 1911. This happens when you cancel the job manually or when a timeout occurs.

Does the error happen each time you try to run the calculation with a certain set of inputs?


Thanks for your reply! This was the first time the error in the ss occurred to me, that’s why I was curious why it happened. I used similar input, and generally, if an input might generate errors (that I know of) the app raises an error and tells the user what to change.
However, the timeout thing, just happens randomly. This means that for the same input I sometimes get this timeout execution error, but sometimes it just works. This makes it difficult for users and the app unstable.
Do you know why this might happen and a possible solution for it?

I am not sure if I follow. A timeout will always happen after a fixed amount of time, that you can set on the execute method in your appcode. From the logging I don’t expect the timeout on the excel analysis to occur as previous jobs run for a longer amount of time.

You said that you use the Excel worker in combination with the Generic worker. How do you control this from the user interface? Is the Excel worker triggered from a view or from an AnalysisButton?

It’s triggered from a view. You can see in the ss the error I get

and that for the same input it worked after.

Nothing changed in the Viktor input. I just pressed the update button again.

Can you also post the logging from the viktor-cli to include the excel analysis as well? In your screenshot it seems that the error is actually originating from the generic analysis

Can I access somehow the ones from the generic worker? I closed it a lot ever since…

Yes, you can find the logs in C:\ProgramData\Viktor\Viktor worker for ... \logs

The ss I showed there, was indeed because of the generic worker, there was a file missing and it was giving the error.
In this ss you can see the excel worker error I am talking about :

The generic worker was not part of the app then.
It times out, and then when I retry it is working, even if I don’t modify any input, I just press Update again. At that moment, there was no generic worker integrated.

Hi Monica,

It is still a bit difficult for me to completely understand what is happening. I asked @kvangiessen to have a look at this with you