Error while creating the workspace

Which tool versions are you using?

SDK: v13.0.0
Platform: v23.06.2
Python: v3.9
Isolation mode: venv

Current Behavior

Getting error while creating a workspace

Expected Behavior

After publishing an app, I should be able to create a workspace.

Context (optional, but preferred)

I am trying to construct a pipeline of connecting Rhino-Grasshopper file to Viktor. To do so I have using the same file which is availabe on Github Viktor repositiries and have followed all the 6 steps which is mentioned in readme file. Further, I published an app in the created app “ghsampleproject” but I am unable to create workspace because of some error.

I request you’all to please suggest me on this.

Thank you.

Hi Darshan,

Welcome to the community forum, thanks for posting!!

There are two points I’d like to address regarding the application you are trying to publish. I’ll start with the simple one: the python version, I see in your screengrab that you’re getting warnings regarding your python version, while you seem to be using python 3.9 the app itself is still running on python 3.7, did you specify a python version in the viktor.config.toml file as the warning suggests? If not, please specify the python version there as well, preferably the one you are actively using (3.9). This means adding python_version = '3.11' to that file.

The next point is addressing the error when creating a workspace. Are you using the full code of the repository you linked to? For convenience I am going to assume you did, especially seeing that you are using SDK v13.0.0.
The problem with that is that you are only allowed to publish apps in public workspaces, while the version of the app you are using is of the app-type tree, while public workspaces can only be created for apps with app-type editor. A solution would therefore be to use the version which has been updated to be of that app-type. I’ve updated the repository to fit these requirements.
Note that it is not possible to switch the app-type of a single app so you will have to create a new app in your environment to publish this new version in. Once you’ve done so you will be able to create a public workspace for that newly published app.

Hopefully this all helps and if you have any questions feel free to let me know in this thread!

All the best and happy coding!

Hello Daniël, thank you for your suggestion and help.

After downloading the updated file, and going through all the steps with any modification. I was able to create a app and publish it, but I’m getting an error while loading the model. As you can see in the attached screengrab, the parameters are visible but it fails to visualise the result.

For better clarification, I would like to mention that whenever I click on Update Button, the Rhino-Grasshopper software runs automatically on my system and the model is visible in the Rhino, later it closes, so according to me it means the apps has established connection with the Rhino-Gh file but failing to visualise in Viktor.

Would be great if you please guide on this, thank you in advance.


Hi Darshan,

Thank you for the elaboration, that clarifies a lot.
Indeed you are correct in assuming that the app is making contact with Rhino/Grasshopper.
Therefore the problem must lie in the conversion back from the Grasshopper output to the visualization in your GeometryView.
One question I still have is whether this did work in your development workspace? If it also doesn’t work there, we could possibly get more of an idea where the problem lies.
Moreover if you run the worker directly (meaning not headless) you could check the traceback of the worker there.

Hello Daniël, it is working in development workspace but still not functioning in the workspace.

Please guide me on this.
Thank you.

Hi Darshan,

In Daniël’s first reply he mentioned that the app type needs to be editor, not tree. There is a good chance you have a tree type app when I look at the screenshot. You can check this in your viktor.config.toml file at the top!
If it is a tree type, consider changing it to a editor type, this may need some reworking but that should not take too long!
Hope this helps!

Kind regards,

1 Like

Hello Thomas, thank you for your suggestion.

Actually, I restarted the whole process by following the VIKTOR grasshopper tutorial and it worked completely fine.
Thank you.

Kind Regards,

1 Like