Error to publish and update an app

Which tool versions are you using?

Platform: v2022.x.x??
Python: v3.9
Isolation mode: venv

Current Behavior

(venv) PS C:\Users\xxx\viktor app\CPT-inversion> viktor-cli publish --registered-name norsand-cpt --tag v1.3
INFO: Git repository detected, respecting gitignore.

Exiting because of an error: CreateFile C:\Users\xxx\viktor app\CPT-inversion\venv\Lib\site-packages\matplotlib-3.7.2-py3.9-nspkg.pth: The system cannot find the file specified.

Expected Behavior

I published this app a while ago, but now this error prevents me from publishing an updated version.

Context (optional, but preferred)

Name | Full name | Latest tag | SDK version | Status
norsand-cpt | | v0.1.0 | 14.4.0 | published

I tried to reinstall the app and specified matplotlib == 3.7.2 in the requirement while I don’t need it. But it is not working.


Hi Hao, is the venv directory included in the .gitignore file?

Hi, Yes, it is included.

folder form Pycharm


I tried an old app that was publihsed months ago. Now it says
Exiting because of an error: request returned 403

Hi Hao,

@rdejonge answered this topic in this post, did you see? And if so, did that indeed solve your problem?

Hi Daniel, problem solved, Cheers :grinning: