Error publishing "Exiting because of an error: failed uploading tar"


I’m trying to publish an app and I get the same error everytime “Exiting because of an error: failed uploading tar”.

I’m writing: viktor-cli publish --registered-name --tag v0.2.0
Then there’s a very big list of files. At some point it asks if I want to continue, I reply yes and then the error appears.

I’ve published one app in the past and it was really straight forward.
Can someone please help overcome this issue?

Thanks in advance, Ana

Hi Ana,

Thank you for reaching out. Could you provide information on how large your project is (without the venv folder)?


Thanks for replying. It’s 145MB

Hi @ana.faria ,

Your case has slipped of the radar. My apologies. Could you update your viktor-cli with the following command:

viktor-cli upgrade

And then try to republish your app?

Again my apologies for not responding further.

Hi @mslootweg

No worries, I’ve been busy with other apps so I didn’t move further with this one yet.

I updated and tried to upload again.
Now I’m getting an error that states that there’s a folder missing in my venv/lib. I’ve been adding those missing folders as requirements and everytime (for the last 3 times at least) it has been asking me for a different one.
My guess is that the library that I originally used (FoundationDesign) needs these other libraries but they aren’t being installed when I do install FoundationDesign.
If I manually add all the libraries I should be able to publish, right? Is there an easier way to work around this?

Thanks for your help.

Hi @ana.faria ,

When you are referring to the errors you are receiving, I’m assuming that you get these while you are starting up the app? Or is it during the publishing?

If it is during development, make sure that if you switch projects to first clear and install the app before starting:

viktor-cli clear

Followed by…

viktor-cli install

Followed by…

viktor-cli start

It is indeed so that any package that you are using should be listed in your requirements.txt file. These packages can only be one listed on PyPI:

I’ve checked, and FoundationDesign is listed, so that should not be an issue.

Note that during publishing, the project will be packed and sent whilst ignoring your venv folder. This is done because all the requirements will have been defined in the requirements.txt file.

Make sure that, if you are using git, to commit your changes before publishing, because this is also respected.

Hopefully this provides all the checks necessary to get your app published. Let me know how you progress.


Thanks for the reply.
My issues were when publishing. I updated my git repository and that solved the issue of “missing some libraries” but the initial problem came back “Exiting because of an error: failed uploading tar”.

I’ve noticed that on the viktor dashboard I still see the app publishing (even after the error) for about 30min and then it returns error.


Thanks for checking. Could you check your internet speed? I will check internally whether there are other points we could check.

@mslootweg my internet seems to be ok. It’s at 125Mbps download and 65Mbps upload.
Thanks for checking, maybe the issue comes from some missing tar file, but I can’t figure out why it would be missing.

To give a bit of context, when using the command viktor-cli publish, the app starts a process to publish the app which starts by packing and sending the code. This project code is packed to a tar file, then sent to the VIKTOR platform to continue the process of publishing.

You mentioned that the size of the application is 145MB, right? Let us assume that for some reason some other unnecessary files are being packed and sent with. Could you delete the venv file? And before publishing, make sure that the folder is not bigger than that.

Also, make sure when publishing, that the list of files that are being sent is indeed what you expect to publish. It could sometimes happen that one publishes some other files by accident.

This list of files is shown right after you used the viktor-cli publish command

It WORKED!! Thanks so much for your support.

For future reference I had to delete the venv folder, update my git repository and then publish. Even though my folder was a bit over 145MB (~200MB) it is now online!

Thank you very much for your help.

1 Like

That’s great! To ensure that git ignores the venv folder, make sure to add a .gitignore file to your repository, with the files and folders you want to exclude. Here is an example of such a .gitignore file, for future reference:

1 Like