Dfoundation worker not working on server

We have some workers installed on a server. However, the Dfoundations worker malfunctions in some cases while running the worker locally as a developer does not crash.

We get the following error in the log of the viktor worker:
2024-03-28 14:26:46 ERROR EXECUTION_ERROR: D-Series did not start properly. Check correctness of input file and installation

Does somebody have any suggestion on how to fix/troubleshoot the issue? Is it maybe possible to enable more advanced logging?

Version information:

  • Workers version 5.5.0
  • Dfoundations version 22.1

Hi Vincent,

Are you able to compare the input files youโ€™re using in case youโ€™re running in development versus when in production?

Hey. We didnโ€™t check the files but they must be same. What we did is we switched the worker from the production to development worker and then it worked. Same workspace and same button.

Great that you managed to get it to work. It sounds like the other worker that was dedicated for production was somehow broken, maybe pointing to a wrong workingDirectoryPath?

Dfoundations it self seems to be working fine on the server. All worker tasks previous to the problematic worker call worked fine. So using dfoundations for that worker call locally works but just not on the production worker server.

WHere can we find workingDirectoryPath? In the worker config there is only an entry for the installation path of dfoundations.