Demo couldn't start, access denied

is this an issue with the multiprocessing library? or something with viktor?

Let’s start with a ‘shot in the dark’, before we dive deeper…

What version of Python are you using? This stackoverflow question mentions a similar error, which is caused by Python version 3.7.2. Upgrading to the latest patch version resolved this issue.

I’ve installed new python 3.10
but when i run viktor-cli start it still looks at old python37 folder
3.10 has been installed to PATH. How do i get viktor to recognize it?
Thanks!

If both Python installations have been added to the PATH variable, but the python command starts a Python 3.7 interpreter instead of 3.10 this means that you should modify the order of the directories in your PATH variable. The directories of Python 3.10 should be placed above the 3.7 installation. You can use the ‘Move Up’ button for this.

For more info on environment variables see: https://www.howtogeek.com/787217/how-to-edit-environment-variables-on-windows-10-or-11/

I’ve deleted 3.7 from my system.
python starts 3.10
but viktor says python isn’t installed at all

how do i change viktor’s “recognized” python location?

The latest CLI version includes a prompt to supply a path to your Python installation.

From the screenshot I see that you still need to update. You can do this with viktor-cli upgrade. Afterwards you can reconfigure the CLI with viktor-cli configure. To keep previously defined settings you can just press enter to keep the current settings. The last step in the configuration process will allow you to supply a path to your pyhton installation

doesn’t seem to change anything

Hi Will,

Did you reinstall before using viktor-cli start? I think the problem is caused by the fact that a pyvenv.cfg file is present in the venv folder of your app that still points to the old Python installation. Use viktor-cli install to delete the old venv folder, create a new virtual environment and install the app’s dependencies. After that you should be able to start the app with viktor-cli start.

Otherwise check that the old path to your previous Python installation is not present as a value in the PATH environment variable. See this link for more information: django - no python at "C:\Users\AccountName\AppData\Local\Programs\Python\Python38-32\python.exe" error in VsCode - Stack Overflow.

Regards,

Raoul