Demo app doesn't start

Which tool versions are you using?

SDK: v13.?.?
Platform: v2022.?.?
Python: v3.11.2
Isolation mode: venv/docker

Current Behavior

demo app doesn’t start

image

Expected Behavior

demo app should start

Context (optional, but preferred)

testing viktor app for problably use

Hi Stijn,

Could you share the output from viktor-cli when you run the get-started command in Powershell?

Regards,

Raoul

do you mean this command: get-started cloud.viktor.ai.viktor.ai ? if so
the thing it said was this: Exiting because of an error: could not obtain activation code
and because it didn’t work with powershell i have done it in the command prompt , and that why i looked to the fact that my acount was activated , but that said that my account was already activated, and for the rest i got only one popup , what possibly explains the problem and that is this

What is the output when you run viktor-cli get-started cloud.viktor.ai manually in Powershell? (so not cloud.viktor.ai.viktor.ai, the interface contains a typo).

I just get another activation code

i just tried ik again, i stil get the activation code but also i get a error
image

The activation code expires after 1 minute, after which this error is shown in your Powershell. You should be able to fill in the activation code in your browser (as you have done previously?) within this time frame. You can request a new activation code by running viktor-cli get-started cloud.viktor.ai infinite times if the activation didn’t succeed yet.

We are mainly interested in the output of the viktor-cli in the Powershell after you activated your account and the “Failed to launch the demo app automatically” shows up in your browser. The error messaging in the Powershell might give is valuable information on where the problem you encounter originates from.

that was on the account that i had to type in the activation code , not in the powershell

i got this message first


but after a while (longer than 5 minutes but i do not remember how long exactly ) this message came up
image

whit other words I didn’t get anything in PowerShell no error showed up in PowerShell, therefore i can’t give other error messages because there wheren’t any

the only thing what i can give you more is about the message that i got from the firewall is that our IT person said that it tried to access a external host and change the virtual memory and that my company can’t allow this on their devises

What does it show when you run viktor-cli check-system in the Powershell?

this

Looking at the output, it seems the viktor-cli fails before the first test, trying to connect to an external host URL. It seems your firewall blocks any connection of the viktor-cli with the internet. To be able to use VIKTOR and the viktor-cli, access the VIKTOR environment over the internet is necessary. Please contact your IT department to check whether restrictions can be loosened accordingly.

More on the prerequisites can be found in our docs

You can get a more detailed summary on what went wrong by running the following command:

viktor-cli check-system --verbose

I have already done that and what the it guy said is it tried to access a external host and change the virtual memory and that my company can’t allow this on their devises but it is appearing to work on the devise of my manager and he has already asked to whitelist this but our IT guys first want to evaluate the risk and we haven’t heard form it for now

the only difference between the output from viktor-cli check-system and viktor-cli check-system --verbose
is this : Executing curl -v -I --fail http://neverssl.com --max-time 5: