Cannot publish app with self created wheels

It seems impossible to create an app that uses a wheel that I created myself. We have been working with submodules, but since we are getting a lot of them we want to check if we can work with wheels instead.

Unfortunately when Publishing wheels to the Viktor Server it fails every time. But I do not get any more info about why it crashes.

So I have a wheel and try to install it via the requirements.txt as follows:
# viktor==13.7.1
./dependencies/ViktorShared-; platform_system != "Windows"

But this does not seem to work. The wheel only contains one package and one function. Can you tell me if it is possible to work with wheels like this? Or what is going wrong in my code?

Can you check whether the Python version for publishing is the same as the wheel’s version (3.10), in your viktor.config.toml file?

I expect it to work, based on previous forum posts:

Hi @sjoerd.hoekstra.tauw,

I came across the same error twice. The first time, it was solved in the VIKTOR back-end. The second time, it had to do with the order of committing and publishing. First, commit the changes to Github, then publish the app. I have no idea why it has to be in this particular order, but it works fine on my side.

By the way, the names of my local wheels are something like this:
They are OS-independent and have Python 3 as the programming language. Maybe you could try that as well?

I hope it helps you further. Good luck!