AttributeError: 'GEFController' object has no attribute 'views'

Hi, I’m getting the following error when trying to start up our app:

2022-01-10 15:35:26.012 INFO : VIKTOR connector v5.1.2
2022-01-10 15:35:26.012 INFO : VIKTOR SDK v12.6.0
2022-01-10 15:35:26.012 INFO : Loading app…
2022-01-10 15:35:27.952 WARNING : /usr/src/packages/yaml/ DeprecationWarning: Using or importing the ABCs from ‘collections’ instead of from ‘’ is deprecated since Python 3.3,and in 3.9 it will stop wo
if not isinstance(key, collections.Hashable):

Traceback (most recent call last):
File “”, line 1, in
File “src/connector.pyx”, line 669, in init connector
File “src/connector.pyx”, line 570, in connector.load_manifest
File “src/connector.pyx”, line 517, in connector.load_manifest._preprocess_entity_types
File “viktor/core.pyx”, line 1532, in viktor.core._handle_job
AttributeError: ‘GEFController’ object has no attribute ‘views’

I have tried the following:

  • Go back to a version that I am certain works (from last week), clear the CLI, install. Even this version gives the same error.
  • Start a different app (in fact, the spreadsheet tutorial app). This works. In fact, both the version that ended up not working and the version I know works, work on my coworker’s machine
  • Restart computer, reinstall
  • Clear the CLI, restart computer, reinstall
  • Delete the related Viktor-Install directory, clear the CLI, reinstall

The only thing I realistically changed when installing (right before I started getting the error) was the import of another python package through the requirements file, but I am not sure if this is related. This requirement has since been removed.

I am also getting the following line in my Ubuntu terminal on startup, of which I also don’t know if it’s related:

-bash: /home/ron/.bashrc: line 118: syntax error near unexpected token (' -bash: /home/ron/.bashrc: line 118: export PATH=/home/ron/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/lib/wsl/lib:/home/ron/viktor-apps/

Hi Ron,

It seems that the connector version that is installed is very old. When installing an app (viktor-cli install), this should automatically install the latest one. Which command do you use to install the app?

1 Like

Hey Kevin,

I used the following command:

./viktor-cli install --connector 5.2.0

For which the --help command says that 5.2.0 is my default:


I’ve ignored the --help message now and used --connector 5.9.1 on the install, with which it does work. So thank you!

Ah that explains!

The 5.2.0 is just an example of how to specify a version. We will always try to keep the connector backward compatible, so I would advise you to not specify a connector version at all. We cannot guarantee that older versions keep working with newer versions of for example the viktor-cli or the SDK.

Hey Kevin,

Normally I wouldn’t use the connector flag, but because of our CLI connection problems I am forced to!

Anyway, I know how to do it now, so it won’t be a problem anymore :grinning_face_with_smiling_eyes: