Unable to install Geolib+

Besides Geolib I also want to use the Geolib+ package (Github / Pypi ) in my app. I therefore added the following line in the requirements.txt:

d-geolib-plus==0.1.2

However, I when installing the app using viktor-cli install I get the error below. Can someone tell me the correct way to use the package in the app?

SDK version: 13.2.1 Connector version: 5.16.0
Creating app specific install dir pip-cache
Creating app specific install dir signals
Looking in indexes: https://martijn.kriebel%40wsp.com:****@sys.viktor.ai/api/v1/packages/
Collecting viktor==13.2.1
  Downloading https://viktor-system.s3.amazonaws.com/packages/viktor/viktor-13.2.1-cp37-cp37m-linux_x86_64.whl?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIA53GKZRCUAHO7GC7K%2F20220803%2Feu-central-1%2Fs3%2Faws4_request&X-Amz-Date=20220803T102108Z&X-Amz-Expires=300&X-Amz-SignedHeaders=host&X-Amz-Signature=c09de506aeecb751bbd25ced9c78552610d96fc05b4ba27017bb5cce988024e7 (25.9 MB)
     |████████████████████████████████| 25.9 MB 281 kB/s
Collecting viktor-connector==5.16.0
  Downloading https://viktor-system.s3.amazonaws.com/packages/viktor-connector/viktor_connector-5.16.0-cp37-cp37m-linux_x86_64.whl?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIA53GKZRCUAHO7GC7K%2F20220803%2Feu-central-1%2Fs3%2Faws4_request&X-Amz-Date=20220803T102114Z&X-Amz-Expires=300&X-Amz-SignedHeaders=host&X-Amz-Signature=33ef925b7b6eecb8c48f54d53272167371658461cd37cdc5ba67483cb99daf79 (2.2 MB)
     |████████████████████████████████| 2.2 MB 9.8 MB/s
ERROR: Could not find a version that satisfies the requirement d-geolib-plus==0.1.2 (from versions: none)
ERROR: No matching distribution found for d-geolib-plus==0.1.2
Exiting because of an error: installation of the app failed

Hi Martijn,

Which Python version are you using? It seems that geolib+ is only available for Python versions 3.8 and 3.9 at the moment, see the ‘meta’ column: d-geolib-plus · PyPI.

If this indeed solves the problem, make sure that when you publish your app you specify the correct Python version in the config: Support for Python 3.7 - 3.10 🐍 - #2. It seems that we released this feature just in time;)

Regards,

Raoul

Hi Raoul,

Thanks for your response! I defined Python version 3.8 in the viktor.config.toml file, but apparently I made a typo causing the app to ignore this. After fixing this I had no troubles importing Geolib+ :slightly_smiling_face: