No support for matplotlib >= 3.7.0 by Viktor >=13.7.2

Hi ! We have a problem trying to update to the latest Viktor SDK (13.8.0) with Python 3.11. Sadly is our version of matplotlib not yet supported :frowning:

Hi Enrique,

Matplotlib ships with the VIKTOR sdk, so even without listing it in the requirements.txt you can import the package in your python files after viktor-cli install. Is there a specific reason that you need a newer version of matplotlib?

Hi Yannick, we would like to ship new products with the latest dependencies to avoid starting with technical debt. Is there a specific reason why Viktor wouldn’t want to support the latest version of matplotlib?

Hi Enrique,

I see that the newest Matplotlib v3.7.0 is only released two weeks ago, so it’s not yet included in the platform. Do you have a specific need for any of the new Matplotlib features? If not, you should be fine with the previous version. I would not worry about technical debt as it’s a well tested package.

It’s a new app (from last week), so we were already using matplotlib 3.7.0 in combination with Viktor 13.7.1. That means we have to roll back to an older version of matplotlib to be able to work with the latest versions of Viktor. For now, we will do that, but it feels like a workaround to us.

Hi Enrique,

The matplotlib requirement has not changed from viktor version 13.7.1 => 13.8.0. For both viktor versions the required version is <3.7.0,>=2.2.2. To be sure I tried to install an app with following requirements:

# viktor==13.7.1

And with updated VIKTOR SDK version:

# viktor==13.8.0

In both cases the installation fails (as expected). Could you check again if you are in fact able to install your app with above requirements?

Hi Enrique,

This has been fixed in the v14 release (SDK v14 released 🎉).

Please don’t hesitate to contact us if you experience trouble upgrading!

1 Like