Dynamo worker not running an analysis


I completed the tutorial for creating a method to update a dynamo file. I got the worker running and I pasted all the code into a new project. But i still run in to a problem with the worker analysis.

I used the executable down below but the worker doesn’t succeed in generating a output.xml or geometry.json file. Anyone who might know a solution?

    path: 'C:\Program Files\Autodesk\FormIt\DynamoSandbox\DynamoWPFCLI.exe'
    - '-o'
    - 'input.dyn'
    - '-v'
    - 'output.xml'
    - '-gp'
    - 'C:\Program Files\Autodesk\FormIt'
    - '-g'
    - 'geometry.json'
maxParallelProcesses: 1 # must be one, please do not change

Tutorial - Dynamo model | VIKTOR Documentation

2023-06-19 11:56:55 INFO Sending result_pointer: 99959
2023-06-19 12:02:27 INFO Received (1) job_pointer: 99962
2023-06-19 12:02:33 ERROR READ_ERROR: Output file C:\ProgramData\Viktor\Viktor worker for generic v5.3.2\jobs\9eaa8d9d-12d3-4c22-9b7d-a693540c56ff\geometry.json does not exist
2023-06-19 12:02:33 INFO Sending result_pointer: 99962

Hi Sven,

Welcome to the community forum, thanks for posting!

Great that you managed to get everything installed and running, but I can imagine it’s a bummer if the last step in the process fails.

Just some initial questions first:

  • Did you check whether the two paths mentioned in the executable in the config.yaml of the worker are correct? both the path (which points to your installation of DynamoSandbox) as well as the variable below -gp (which points to your installation of FormIt) should be correct. So please check whether those installations can actually be found on those locations.
  • Do you have the proper licenses active? As in, are you able to run both FormIt and Dynamo by hand?

If you checked these two things and the analysis still isn’t working, we’re going to have to dive a little deeper, but let me know if this is all in place first, to save us some unnecessary work :wink:

Hi @Daniel ,

Thanks for the quick reply! I’ve checked both paths and they both go to to the right folder. I can run both programs by hand. But I have FormIt Pro installed, not sure if that limits a few things?


Update: I uninstalled my version of FormIt and I used the link in the tutorial. It automatically installs FormIt Pro, and it doesn’t work either. It must be something else i think?

Hi Sven,

Interesting. The installation of FormIt Pro indeed isn’t the issue, that is just the regular installation as you should have (I have the same on my end).

You could check whether the running of the script works at all, to do this you can open a command prompt in any directory you like (assuming you are using windows as os?) and entering the following command:

"C:\Program Files\Autodesk\FormIt\DynamoSandbox\DynamoWPFCLI.exe" -o "C:\<YOUR PATH TO DYNAMO FILE>\dynamo_model_sample_app.dyn" -v "output.xml" -gp "C:\Program Files\Autodesk\FormIt" -g "geometry.json"

After that a geomtetry.json file as well as a output.xml file should be present.
I’m wondering if this does work, please let me know!

Hi Daniel,

I get the following message in command prompt:

Very peculiar, do I understand correctly that you’ve got the .dyn file stored on a devops environment? Maybe storing it locally could help?

Hi @Daniel,

I’ve put the file on desktop, still the same error message.

Hi @Daniel,

I am curious if there might be a solution for this user case?

After reinstalling formit the worker seems to work :slight_smile:

However, i get the following warning on the geometry converter:
Any idea on what could go wrong? I tried using both the tutorial files and files i created myself.

Hi Sven,

One of our other commmunity members, @Bayo , also encountered the same issue. In this post he seemed to have solved this:

1 Like

This has been fixed in SDK v14.6.1