Change in Table behavior


I noticed a change in the table behavior.

Tables used to look like this:

They now look like this:

With the new tables I can’t:

  • CTRL + Z to undo changes in the table
  • Copy+paste single or multiple cells, or entire tables
  • Use enter to add a new row

This makes tables much more difficult to work with. Is it possible to add these functions back, or revert to the old style tables until all features are fleshed out?

Hi Ron,

(aside: we unfortunately had to rollback the platform version due to another issue. the new table will become available again after this is fixed, but is currently not present)

Thanks for the feedback.

We indeed changed the tablefield in the latest platform release. The reasons for these are:

  • improved stability: the previous table implementation was difficult to maintain and we think this new implementation improves this situation
  • more extension possibilities: there are a lot of feature requests around the tablefield. this new tablefield is a better starting position for feature additions

To answer on your observed shorcomings:

  • CTRL + Z support: we are aware of this, but prefer working on a global undo command that also work for the other fields in the editor
  • Copy-paste: i have trouble replicating your issue and we have tested this extensively before rollout. Could it be that your browser blocks access to the clipboard? What browser are you using?
  • Enter to add new row: the enter input triggers the edit mode of the cell, which is the same as how this works in google sheets. It also jumps to the next row if available, but indeed does not create a new row if it is the latest. We are aware of this limitation, can you explain why this functionality is important for you?
1 Like

Hey Matthijs,

Good to hear that the tablefield is getting some love :slight_smile:

Thank you for your reply! To answer your answers:

  • CTRL + Z support: I could get behind a global undo command, as long as there is an undo command. Especially when copy pasting parts of a table, it’d be nice to have one.
  • Copy-paste: I’m using MS Edge. With the rollback I am able to copy-paste again, which I also was before the update. So I don’t think my browser blocks these actions?
  • Enter to add new row: The problem with the comparison to Google Sheets is that the Tablefield rows are finite and start at 1, whereas Google Sheets for most purposes has an unlimited number of rows. For the TableField, if I want a certain number of rows, I have to do the same two actions multiple times, namely right click, and click on add row. While I could just use enter before the update. From a QoL point of view, I consider this part of the update a downgrade.
1 Like

Hi Ron,

I’m investigating the issue you’ve mentioned with the new table field provider not working correctly in MS Edge. We did not catch any issues in it during internal testing, and I can’t seem to reproduce the problem myself. This is how it works on my end:


Could you give us some extra information, like:

  • do you run any browser extensions that might interfere with the table hotkeys? Can you try disabling them if you do?
  • can you change other fields? Is the editor in read-only mode?
  • what kind of an app are you running (public/non-public, does the editor have pages/steps, regular/input-only/views-only)?
  • have you tried opening it in Firefox or Chrome, and do you experience the same issue there?

Thanks for the information,

We’ve discovered one more thing that could be causing the copy problem - browser permissions. If you have previously denied access to your clipboard, you will need to allow it again in order for copying to work:

1 Like

Hey Tom,

That seems to have fixed it. I am quite shocked, since copying into the other table did work, and I don’t remember blocking permission to the clipboard for any website in my life… Thank you!