App not publishing: 'Workspace could not be upgraded to the new version'


When I publish this public app everything runs fine until I look in my workspace. There the following error message is shown. In the CLI (version 0.27.4) the app is shown with the correct version. SDK = 13.6.2

Any ideas?



Hi Bart,

Sadly this issue is currently only fixable through some intervention from VIKTOR’s side. We are working on providing admin tools in the platform in order to give you the opportunity to fix it yourself. Once this feature has been released I will update this post.

In the meantime I’ve created an internal request to resolve your specific issue from our side. I will keep you personally updated on when this should be fixed.

Hi Daniel, Thanks for the support. Let me know when I can retry.

Hi Bart,

The issue has been resolved from our side.
It arose when you tried to publish a simple app-type to a workspace which has its visibility set to public. It is only possible to publish editor app-types to such workspaces. We are working on better error messages to inform users if this happens.

For now your workspace visibility has been set to private which allowed the publish to go through.

Though, in order to publish your app publicly your app has to be adjusted to the app-type editor. You will also have to create a new app in your environment. Because the existing app has already been published as a simple app-type this means that a database has been created. To prevent data from being lost it is not possible to change this existing app to editor app-type (which has no data attached).

So the flow in your case is: change the app-type in the code to editor → create a new app in the environment → create a new workspace for this app to live in → then you can publish your code to the new app.

Hopefully this helps

Hi Daniël,

Thanks! I forgot to change the app-type to ‘editor’. Now I did and tried to publish the app into the private workspace. However I get the following message:

If I try to change the workspace to public again before publishing it gives an error as well.

Any idea? Thanks!